$re = '/.*/m';
$str = '| Year | value |
| - - - | - - - |
| 1956 | 135436132 |
| 2001 | 86435233 |
| 2008 | 1368543 |
| 2077 | 168463213 |
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);