import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*";
final String string = "| Year | value |\n"
+ "| - - - | - - - |\n"
+ "| 1956 | 135436132 |\n"
+ "| 2001 | 86435233 |\n"
+ "| 2008 | 1368543 |\n"
+ "| 2077 | 168463213 |\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}