package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s*\*$`)
var str = `this is a string *`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}