$re = '/\s*\*$/';
$str = 'this is a string *';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;