use strict;
my $str = 'this is a string *';
my $regex = qr/\s*\*$/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";