using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(https?:\/\/|www\.)[a-zA-Z0-9-_\.\/\?=&]+";
string input = @"Un message avec un lien http://primfx.com/ :) www.primfx.com";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}