$re = '/(https?:\/\/|www\.)[a-zA-Z0-9-_\.\/\?=&]+/';
$str = 'Un message avec un lien http://primfx.com/ :) www.primfx.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);