package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(https?:\/\/|www\.)[a-zA-Z0-9-_\.\/\?=&]+`)
var str = `Un message avec un lien http://primfx.com/ :) www.primfx.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}