#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\!(.*(jpg|png|gif|pdf|xlx))|(|width=})!"
Local $sString = "!img2.png|width=83.33333333333334%!" & @CRLF & _
"" & @CRLF & _
" "!robot (f05f0216-caf4-4543-a630-99c2477849d5).png|width=400,height=400!" " & @CRLF & _
"" & @CRLF & _
" "!abc.pdf|width=200!"" & @CRLF & _
"" & @CRLF & _
" "!dfe.xlx"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")