const regex = /\!(.*(jpg|png|gif|pdf|xlx))|(|width=})!/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\!(.*(jpg|png|gif|pdf|xlx))|(|width=})!', 'gm')
const str = `!img2.png|width=83.33333333333334%!
"!robot (f05f0216-caf4-4543-a630-99c2477849d5).png|width=400,height=400!"
"!abc.pdf|width=200!"
"!dfe.xlx"
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}