using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\!(.*(jpg|png|gif|pdf|xlx))|(|width=})!";
string input = @"!img2.png|width=83.33333333333334%!
""!robot (f05f0216-caf4-4543-a630-99c2477849d5).png|width=400,height=400!""
""!abc.pdf|width=200!""
""!dfe.xlx""
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}