using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!(([^""]*""){2})*[^""]*$)\n+";
string substitution = @"";
string input = @"""Lorem Ipsum"";""lorem lorem
ipsume
fezohf
pefz
"";""
""dzafmkahvgaez"";""oufhbezoà"";"" bfoezi"";""dzadaz
dazdjha
daz
""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}