re = /(?!(([^"]*"){2})*[^"]*$)\n+/
str = '"Lorem Ipsum";"lorem lorem
ipsume
fezohf
pefz
";""
"dzafmkahvgaez";"oufhbezoà";" bfoezi";"dzadaz
dazdjha
daz
"'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result