using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"token=(.*?)&filter=\s*([\w]+)\s*([\w]+)";
string input = @"api/evenSession/123123123/eventSession?token=1234656&filter= chris moreno";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}