package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)token=(.*?)&filter=\s*([\w]+)\s*([\w]+)`)
var str = `api/evenSession/123123123/eventSession?token=1234656&filter= chris moreno`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}