const regex = /token=(.*?)&filter=\s*([\w]+)\s*([\w]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('token=(.*?)&filter=\\s*([\\w]+)\\s*([\\w]+)', 'gm')
const str = `api/evenSession/123123123/eventSession?token=1234656&filter= chris moreno`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}