using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^\d{2})?(\d{2})(\d{2})(\d{2})_";
string substitution = @"$1$2-$3-$4 ";
string input = @"20181019_210353_BURST2.jpg";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}