package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(^\d{2})?(\d{2})(\d{2})(\d{2})_`)
var str = `20181019_210353_BURST2.jpg`
var substitution = "$1$2-$3-$4 "
fmt.Println(re.ReplaceAllString(str, substitution))
}