import Foundation
let pattern = #"(^\d{2})?(\d{2})(\d{2})(\d{2})_"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"20181019_210353_BURST2.jpg"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2-$3-$4 "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)