$re = '/\[(.*?)\]/';
$str = '[1379082600-1379082720],[1379082480-1379082480],[1379514420-1379515800],';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);