re = /\[(.*?)\]/
str = '[1379082600-1379082720],[1379082480-1379082480],[1379514420-1379515800],'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end