package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*(?:\b(?:and|or)\b|[,.])\s*`)
var str = `make the cake, walk the dog, and pick-up poo.
flour, egg-whites and sand.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}