re = /\s*(?:\b(?:and|or)\b|[,.])\s*/m
str = 'make the cake, walk the dog, and pick-up poo.
flour, egg-whites and sand.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end