$re = '/\s*(?:\b(?:and|or)\b|[,.])\s*/m';
$str = 'make the cake, walk the dog, and pick-up poo.
flour, egg-whites and sand.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);