using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[\w&+'])(?![\w&+'])|(?<![\w&+'])(?=[\w&+'])";
string input = @"This is a +sentence& &&with++ such words.
But it treats + and &&&+++ as words.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}