re = /(?<=[\w&+'])(?![\w&+'])|(?<![\w&+'])(?=[\w&+'])/
str = 'This is a +sentence& &&with++ such words.
But it treats + and &&&+++ as words.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end