$re = '/(?<=[\w&+\'])(?![\w&+\'])|(?<![\w&+\'])(?=[\w&+\'])/';
$str = 'This is a +sentence& &&with++ such words.
But it treats + and &&&+++ as words.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);