#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\d)\d{3}\-\d{3}\-\d{4}(?!\d)"
Local $sString = "My number is 0415-555-42424854-201." & @CRLF & _
"My number is 415-555-42424854-201." & @CRLF & _
"My number is 0415-555-4242." & @CRLF & _
"My number is 415-555-4242." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")