re = /(?<!\d)\d{3}\-\d{3}\-\d{4}(?!\d)/m
str = 'My number is 0415-555-42424854-201.
My number is 415-555-42424854-201.
My number is 0415-555-4242.
My number is 415-555-4242.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end