import re
regex = re.compile(r"(?<!\d)\d{3}\-\d{3}\-\d{4}(?!\d)", flags=re.MULTILINE)
test_str = ("My number is 0415-555-42424854-201.\n"
"My number is 415-555-42424854-201.\n"
"My number is 0415-555-4242.\n"
"My number is 415-555-4242.\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")