import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|:|(?<=\\s))(\\d{3}\\-\\d{3}\\-\\d{4})(?=[\\s,;.]|$)";
final String string = "My number is 0415-555-42424854-201.\n"
+ "My number is 415-555-42424854-201.\n"
+ "My number is 0415-555-4242.\n"
+ "My number is 415-555-4242.\n"
+ "My number is 123-415-555-4242.\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}