const regex = new RegExp('(?:^|:|(?<=\\s))(\\d{3}\\-\\d{3}\\-\\d{4})(?=[\\s,;.]|$)', 'gm')
const str = `My number is 0415-555-42424854-201.
My number is 415-555-42424854-201.
My number is 0415-555-4242.
My number is 415-555-4242.
My number is 123-415-555-4242.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}