#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^\"|\{)"
Local $sString = ""@odata.context": "https://example-app-env.aa01.aaa.aaaa-ad/odata/$metadata#Jobs"," & @CRLF & _
" "@odata.count": 111," & @CRLF & _
" "value": [" & @CRLF & _
" {" & @CRLF & _
" "Key": "aaa1a111-aa11-11aa-a11a-11a1aa11a111"," & @CRLF & _
" "StartTime": "2023-01-20T14:08:34.607Z"," & @CRLF & _
" "EndTime": "2023-01-20T14:08:49.517Z"," & @CRLF & _
" "State": "Successful"," & @CRLF & _
" "JobPriority": "Normal"," & @CRLF & _
" "Source": "Agent"," & @CRLF & _
" "SourceType": "Agent"," & @CRLF & _
" "BatchExecutionKey": "aaa1a111-aa11-11aa-a11a-11a1aa11a111"," & @CRLF & _
" "Info": "Job completed"," & @CRLF & _
" "CreationTime": "2023-01-20T14:08:34.607Z"," & @CRLF & _
" "StartingScheduleId": null," & @CRLF & _
" "ReleaseName": "RobotProdLogin_DEV"," & @CRLF & _
" "Type": "Attended"," & @CRLF & _
" "InputArguments": ""," & @CRLF & _
" "OutputArguments": "{}"," & @CRLF & _
" "HostMachineName": "AAAAAAAA11111"," & @CRLF & _
" "HasMediaRecorded": false," & @CRLF & _
" "PersistenceId": null," & @CRLF & _
" "ResumeVersion": null," & @CRLF & _
" "StopStrategy": null," & @CRLF & _
" "RuntimeType": "Development"," & @CRLF & _
" "RequiresUserInteraction": true," & @CRLF & _
" "ReleaseVersionId": 1111," & @CRLF & _
" "EntryPointPath": null," & @CRLF & _
" "OrganizationUnitId": 1," & @CRLF & _
" "OrganizationUnitFullyQualifiedName": "Default"," & @CRLF & _
" "Reference": ""," & @CRLF & _
" "ProcessType": "Process"," & @CRLF & _
" "ProfilingOptions": null," & @CRLF & _
" "ResumeOnSameContext": false," & @CRLF & _
" "LocalSystemAccount": "AAAAAA01\\AAA11AA"," & @CRLF & _
" "OrchestratorUserIdentity": null," & @CRLF & _
" "Id": 00000" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "Key": "aaa1a111-aa11-11aa-a11a-11a1aa11a111"," & @CRLF & _
" "StartTime": "2023-01-20T14:08:34.607Z"," & @CRLF & _
" "EndTime": "2023-01-20T14:08:49.517Z"," & @CRLF & _
" "State": "Successful"," & @CRLF & _
" "JobPriority": "Normal"," & @CRLF & _
" "Source": "Agent"," & @CRLF & _
" "SourceType": "Agent"," & @CRLF & _
" "BatchExecutionKey": "aaa1a111-aa11-11aa-a11a-11a1aa11a111"," & @CRLF & _
" "Info": "Job completed"," & @CRLF & _
" "CreationTime": "2023-01-20T14:08:34.607Z"," & @CRLF & _
" "StartingScheduleId": null," & @CRLF & _
" "ReleaseName": "RobotProdLogin_DEV"," & @CRLF & _
" "Type": "Attended"," & @CRLF & _
" "InputArguments": ""," & @CRLF & _
" "OutputArguments": "{}"," & @CRLF & _
" "HostMachineName": "AAAAAAAA11111"," & @CRLF & _
" "HasMediaRecorded": false," & @CRLF & _
" "PersistenceId": null," & @CRLF & _
" "ResumeVersion": null," & @CRLF & _
" "StopStrategy": null," & @CRLF & _
" "RuntimeType": "Development"," & @CRLF & _
" "RequiresUserInteraction": true," & @CRLF & _
" "ReleaseVersionId": 1111," & @CRLF & _
" "EntryPointPath": null," & @CRLF & _
" "OrganizationUnitId": 1," & @CRLF & _
" "OrganizationUnitFullyQualifiedName": "Default"," & @CRLF & _
" "Reference": ""," & @CRLF & _
" "ProcessType": "Process"," & @CRLF & _
" "ProfilingOptions": null," & @CRLF & _
" "ResumeOnSameContext": false," & @CRLF & _
" "LocalSystemAccount": "AAAAAA01\\AAA11AA"," & @CRLF & _
" "OrchestratorUserIdentity": null," & @CRLF & _
" "Id": 00000" & @CRLF & _
" },"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")