use strict;
my $str = '"@odata.context": "https://example-app-env.aa01.aaa.aaaa-ad/odata/$metadata#Jobs",
"@odata.count": 111,
"value": [
{
"Key": "aaa1a111-aa11-11aa-a11a-11a1aa11a111",
"StartTime": "2023-01-20T14:08:34.607Z",
"EndTime": "2023-01-20T14:08:49.517Z",
"State": "Successful",
"JobPriority": "Normal",
"Source": "Agent",
"SourceType": "Agent",
"BatchExecutionKey": "aaa1a111-aa11-11aa-a11a-11a1aa11a111",
"Info": "Job completed",
"CreationTime": "2023-01-20T14:08:34.607Z",
"StartingScheduleId": null,
"ReleaseName": "RobotProdLogin_DEV",
"Type": "Attended",
"InputArguments": "",
"OutputArguments": "{}",
"HostMachineName": "AAAAAAAA11111",
"HasMediaRecorded": false,
"PersistenceId": null,
"ResumeVersion": null,
"StopStrategy": null,
"RuntimeType": "Development",
"RequiresUserInteraction": true,
"ReleaseVersionId": 1111,
"EntryPointPath": null,
"OrganizationUnitId": 1,
"OrganizationUnitFullyQualifiedName": "Default",
"Reference": "",
"ProcessType": "Process",
"ProfilingOptions": null,
"ResumeOnSameContext": false,
"LocalSystemAccount": "AAAAAA01\\\\AAA11AA",
"OrchestratorUserIdentity": null,
"Id": 00000
},
{
"Key": "aaa1a111-aa11-11aa-a11a-11a1aa11a111",
"StartTime": "2023-01-20T14:08:34.607Z",
"EndTime": "2023-01-20T14:08:49.517Z",
"State": "Successful",
"JobPriority": "Normal",
"Source": "Agent",
"SourceType": "Agent",
"BatchExecutionKey": "aaa1a111-aa11-11aa-a11a-11a1aa11a111",
"Info": "Job completed",
"CreationTime": "2023-01-20T14:08:34.607Z",
"StartingScheduleId": null,
"ReleaseName": "RobotProdLogin_DEV",
"Type": "Attended",
"InputArguments": "",
"OutputArguments": "{}",
"HostMachineName": "AAAAAAAA11111",
"HasMediaRecorded": false,
"PersistenceId": null,
"ResumeVersion": null,
"StopStrategy": null,
"RuntimeType": "Development",
"RequiresUserInteraction": true,
"ReleaseVersionId": 1111,
"EntryPointPath": null,
"OrganizationUnitId": 1,
"OrganizationUnitFullyQualifiedName": "Default",
"Reference": "",
"ProcessType": "Process",
"ProfilingOptions": null,
"ResumeOnSameContext": false,
"LocalSystemAccount": "AAAAAA01\\\\AAA11AA",
"OrchestratorUserIdentity": null,
"Id": 00000
},';
my $regex = qr/(^\"|\{)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}