const regex = /(^\"|\{)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^\\"|\\{)', 'gm')
const str = `"@odata.context": "https://example-app-env.aa01.aaa.aaaa-ad/odata/\$metadata#Jobs",
"@odata.count": 111,
"value": [
{
"Key": "aaa1a111-aa11-11aa-a11a-11a1aa11a111",
"StartTime": "2023-01-20T14:08:34.607Z",
"EndTime": "2023-01-20T14:08:49.517Z",
"State": "Successful",
"JobPriority": "Normal",
"Source": "Agent",
"SourceType": "Agent",
"BatchExecutionKey": "aaa1a111-aa11-11aa-a11a-11a1aa11a111",
"Info": "Job completed",
"CreationTime": "2023-01-20T14:08:34.607Z",
"StartingScheduleId": null,
"ReleaseName": "RobotProdLogin_DEV",
"Type": "Attended",
"InputArguments": "",
"OutputArguments": "{}",
"HostMachineName": "AAAAAAAA11111",
"HasMediaRecorded": false,
"PersistenceId": null,
"ResumeVersion": null,
"StopStrategy": null,
"RuntimeType": "Development",
"RequiresUserInteraction": true,
"ReleaseVersionId": 1111,
"EntryPointPath": null,
"OrganizationUnitId": 1,
"OrganizationUnitFullyQualifiedName": "Default",
"Reference": "",
"ProcessType": "Process",
"ProfilingOptions": null,
"ResumeOnSameContext": false,
"LocalSystemAccount": "AAAAAA01\\\\AAA11AA",
"OrchestratorUserIdentity": null,
"Id": 00000
},
{
"Key": "aaa1a111-aa11-11aa-a11a-11a1aa11a111",
"StartTime": "2023-01-20T14:08:34.607Z",
"EndTime": "2023-01-20T14:08:49.517Z",
"State": "Successful",
"JobPriority": "Normal",
"Source": "Agent",
"SourceType": "Agent",
"BatchExecutionKey": "aaa1a111-aa11-11aa-a11a-11a1aa11a111",
"Info": "Job completed",
"CreationTime": "2023-01-20T14:08:34.607Z",
"StartingScheduleId": null,
"ReleaseName": "RobotProdLogin_DEV",
"Type": "Attended",
"InputArguments": "",
"OutputArguments": "{}",
"HostMachineName": "AAAAAAAA11111",
"HasMediaRecorded": false,
"PersistenceId": null,
"ResumeVersion": null,
"StopStrategy": null,
"RuntimeType": "Development",
"RequiresUserInteraction": true,
"ReleaseVersionId": 1111,
"EntryPointPath": null,
"OrganizationUnitId": 1,
"OrganizationUnitFullyQualifiedName": "Default",
"Reference": "",
"ProcessType": "Process",
"ProfilingOptions": null,
"ResumeOnSameContext": false,
"LocalSystemAccount": "AAAAAA01\\\\AAA11AA",
"OrchestratorUserIdentity": null,
"Id": 00000
},`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}