re = /^\[(.+)\] (\S+) > (.+)$/m
str = '[Player] Player1 > Hello
[Admin] Alex > Hi
[Player] Player2 > Help me, im stuck
[Mod] Jim > On my way
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end