#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?:\d{2}:)?\d{2}:\d{2}\.\d{3})[^\n]+level[^\d]+(\d{3})"
Local $sString = "00:00.300 ID:4 zzzzzzzzzzz " & @CRLF & _
"00:02.155 ID:4 aaaaaaaaaaaaa " & @CRLF & _
"00:04.662 ID:4 dsadasd " & @CRLF & _
"**00:32.283** ID:4 level **790** " & @CRLF & _
"00:32.155 ID:4 Sfghgfs " & @CRLF & _
"00:32.200 ID:4 Tsdfsdfdfsff " & @CRLF & _
"**00:32.205** ID:4 level **640** " & @CRLF & _
"00:32.206 ID:4 Sadssd " & @CRLF & _
"00:32.208 ID:4 asdasgsfgsgsagsa " & @CRLF & _
"00:32.210 ID:4 adasgx " & @CRLF & _
"00:32.212 ID:4 Masddasdas. " & @CRLF & _
"**01:40:40.698** ID:4 level **500**"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")