# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?:\d{2}:)?\d{2}:\d{2}\.\d{3})[^\n]+level[^\d]+(\d{3})"
test_str = ("00:00.300 ID:4 zzzzzzzzzzz \n"
"00:02.155 ID:4 aaaaaaaaaaaaa \n"
"00:04.662 ID:4 dsadasd \n"
"**00:32.283** ID:4 level **790** \n"
"00:32.155 ID:4 Sfghgfs \n"
"00:32.200 ID:4 Tsdfsdfdfsff \n"
"**00:32.205** ID:4 level **640** \n"
"00:32.206 ID:4 Sadssd \n"
"00:32.208 ID:4 asdasgsfgsgsagsa \n"
"00:32.210 ID:4 adasgx \n"
"00:32.212 ID:4 Masddasdas. \n"
"**01:40:40.698** ID:4 level **500**")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.