$re = '/^ftp\.eset\.sk|mspapi\.esetsoftware\.com$/mi';
$str = 'ftp.eset.sk
mspapi.esetsoftware.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);