re = /^ftp\.eset\.sk|mspapi\.esetsoftware\.com$/mi
str = 'ftp.eset.sk
mspapi.esetsoftware.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end