package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^address\.com/city[^\s/]*$`)
var str = `address.com/city/madrid?source=menu
address.com/city`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}