re = /^address\.com\/city[^\s\/]*$/m
str = 'address.com/city/madrid?source=menu
address.com/city'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end