$re = '`^address\.com/city[^\s/]*$`m';
$str = 'address.com/city/madrid?source=menu
address.com/city';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);