import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=eventtype=)\\S*";
final String string = "(STUNNEL-SECURITY AND NOT (eventtype=sec-stunnel-client-* OR eventtype=sec-stunnel-crl-* OR eventtype=sec-stunnel-loaded-* OR eventtype=sec-stunnel-loading-* OR eventtype=sec-stunnel-no-* OR eventtype=sec-stunnel-openssl-* OR eventtype=sec-stunnel-sconnect-* OR eventtype=sec-stunnel-server-* OR eventtype=sec-stunnel-service-* OR eventtype=sec-stunnel-session-* OR eventtype=sec-stunnel-socket-* OR eventtype=sec-stunnel-ssl-* OR eventtype=sec-stunnel-stats-* OR eventtype=sec-stunnel-threading-* OR eventtype=sec-stunnel-timeout-* OR eventtype=sec-stunnel-various-* ) )";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}