import Foundation
let pattern = #"(?<=eventtype=)\S*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"(STUNNEL-SECURITY AND NOT (eventtype=sec-stunnel-client-* OR eventtype=sec-stunnel-crl-* OR eventtype=sec-stunnel-loaded-* OR eventtype=sec-stunnel-loading-* OR eventtype=sec-stunnel-no-* OR eventtype=sec-stunnel-openssl-* OR eventtype=sec-stunnel-sconnect-* OR eventtype=sec-stunnel-server-* OR eventtype=sec-stunnel-service-* OR eventtype=sec-stunnel-session-* OR eventtype=sec-stunnel-socket-* OR eventtype=sec-stunnel-ssl-* OR eventtype=sec-stunnel-stats-* OR eventtype=sec-stunnel-threading-* OR eventtype=sec-stunnel-timeout-* OR eventtype=sec-stunnel-various-* ) )"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)