package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:(^\([^)]+\))|(\([^)]+\)))([^(<]+)`)
var str = `(smiles) Hello Jane, (quietly) How's the game?
Hello Jane, (quietly) How's the game?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}