re = /(?:(^\([^)]+\))|(\([^)]+\)))([^(<]+)/m
str = '(smiles) Hello Jane, (quietly) How\'s the game?
Hello Jane, (quietly) How\'s the game?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end