using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?:[ \-]?[A-Z][a-z]+|[A-Z][a-z]?\.?)+)(?: ?[A-Z]\.?)* ([A-Za-z]{,3}(?:[ \-]?[A-Z]'?[A-Z]?[a-z]+\.?,?)+[A-Z \-.]*)$";
string input = @"Joel Dorfman
David C. Thomas
George Stager III
Jerome Jay Allen
Shaunda Richardson-Snell
Shelley J. O'Brien
Anthony Stiel, Jr.
James Van Harn II
L. Marcinkowski
S.M. Rutkowski
S. M. Rutkowski
E. Todd Brown
Marc A. ORourke
James CW Roberts III
Holly A. McClellan
Thomas-Robert Peterson
Annette DeLaHuerta
Wm. Craig Faulk
JD Haughey
Adam de Angeli
Keith den Hollander";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}