// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((?:[ \-]?[A-Z][a-z]+|[A-Z][a-z]?\.?)+)(?: ?[A-Z]\.?)* ([A-Za-z]{,3}(?:[ \-]?[A-Z]'?[A-Z]?[a-z]+\.?,?)+[A-Z \-.]*)$").unwrap();
let string = "Joel Dorfman
David C. Thomas
George Stager III
Jerome Jay Allen
Shaunda Richardson-Snell
Shelley J. O'Brien
Anthony Stiel, Jr.
James Van Harn II
L. Marcinkowski
S.M. Rutkowski
S. M. Rutkowski
E. Todd Brown
Marc A. ORourke
James CW Roberts III
Holly A. McClellan
Thomas-Robert Peterson
Annette DeLaHuerta
Wm. Craig Faulk
JD Haughey
Adam de Angeli
Keith den Hollander";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}