use strict;
my $str = 'abc xyz \\a{} mno
\\begin{equation}
\\a{}=a+c
\\a{}=c+b
\\end{equation}
klm mno
\\begin{equation}
x=\\a{}\\times\\b{}
\\end{equation}
xyz mno \\a{} abc';
my $regex = qr/(?:\\begin\{equation\}|\G(?!^))(?:(?!\\a{}|\\(?:begin|end){equation}).)*\K\\a{}/msp;
my $subst = 'xyz';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";